Back to overview
Degraded

Titan Production Incident - Intermittent Titan Emails including MFA

Jun 06 at 10:22am UTC
Affected services
Titan Portal

Resolved
Jun 06 at 05:06pm UTC

The intermittent issue affecting emails from Titan including MFA emails has been resolved. The root cause was down to the provider depreciating certain SSL protocols. An update to the mailer application was made to resolve this.

Please contact #devproductionincidents for any questions

Message Sent By: tmoran@intel471.com

Created
Jun 06 at 10:22am UTC

We are aware of an intermittent issue affecting emails from Titan including MFA emails not being sent.

This appears to be down to an issue communicating with our Primary email provider Sendgrid. Most emails are being sent from the Secondary provider Mailgun.

Please contact #devproductionincidents for any questions

Message Sent By: tmoran@intel471.com