Back to overview
Downtime

Titan Portal and API - Intermittent Outage

Feb 21 at 05:40pm UTC
Affected services
Titan Portal
Titan API

Resolved
Feb 21 at 06:11pm UTC

The issue with Titan Portal and API now looks resolved with our internal monitoring showing healthy states. We will continue to monitor the situation with the upstream vendor Cloudflare. Please send any questions to #devproductionincidents. Sent by: tmoran@intel471.com

Updated
Feb 21 at 05:53pm UTC

There are still ongoing issues with Titan API and Portal related to a Cloudflare outage, we are monitoring the situation and will provide updates when known. Please send any questions to tmoran@intel471.com

Created
Feb 21 at 05:40pm UTC

We are investigating intermittent issues with the Titan Portal and API. There is currently no ETA to resolution. Please contact tmoran@intel471.com with any questions