Back to overview
Downtime

Outage of Titan Portal, Titan API and all services located in DAL

May 14 at 05:41pm UTC
Affected services
Titan Portal
Titan API

Resolved
May 14 at 06:00pm UTC

Titan Portal, API and DAL services have been resolved. A issue with the host of the main gateway has been resolved by a restart and will continue to be investigated.

Created
May 14 at 05:41pm UTC

We are aware of a issue affecting Titan Portal, Titan API and all services located in DAL and are investigating.